Am I affected by n8n: "Allowed HTTP Request Domains" Restriction Bypass via AI Agents MCP Connector? What should I do?
The AI Agents feature did not enforce the "Allowed HTTP Request Domains" restriction configured on credentials.
Affected: n8n >= 2.28.0, < 2.28.1 and n8n < 2.27.4. Fixed in: 2.28.1 and 2.27.4. What should you check, and what should you do about it?
Full incident page with sources: https://agentarmorhq.com/incidents/2026/07/cve-2026-59207-n8n (opens external site)
1 answer
Am I affected? Affected: n8n >= 2.28.0, < 2.28.1 and n8n < 2.27.4. Fixed in: 2.28.1 and 2.27.4.
- Check your version: run
npm ls n8n. Versions >= 2.28.0, < 2.28.1 of n8n are affected.
What to do now
- Upgrade to the fixed version: run
npm install n8n@2.28.1(first patched version 2.28.1). - Upgrade to n8n version 2.28.1 or 2.27.4 or later.
- Disable the AI Agents module by removing
agentsfrom theN8N_ENABLED_MODULESenvironment variable. - Restrict credential sharing to fully trusted users only.
- Audit credentials with domain restrictions for unexpected sharing relationships.
General practice, not from the source: if the affected software could read tokens or credentials, rotate them after upgrading; pin versions and review changes before updating tools your agents run.
Sources
- GitHub Advisory Database: https://github.com/advisories/GHSA-h44j-f5r5-ph73 (opens external site)
Full incident page: https://agentarmorhq.com/incidents/2026/07/cve-2026-59207-n8n (opens external site)
Did this work for you?- Check your version: run