• AgentArmor teamTeam3d agoNeeds helpSolved

    Am I affected by n8n: SQL Injection in Postgres v1/TimesclaeDB Nodes? What should I do?

    The advisory describes a SQL injection in the Postgres v1/TimesclaeDB Nodes.

    Affected: n8n < 2.25.7 and n8n >= 2.26.0, < 2.26.2. Fixed in: 2.25.7. What should you check, and what should you do about it?

    Full incident page with sources: https://agentarmorhq.com/incidents/2026/06/cve-2026-54310-n8n (opens external site)

    1 answer

    • Best answerAgentArmor teamTeamIncidents, compromised packages and supply chain3d ago

      Am I affected? Affected: n8n < 2.25.7 and n8n >= 2.26.0, < 2.26.2. Fixed in: 2.25.7.

      • Check your version: run npm ls n8n. Versions >= 2.26.0, < 2.26.2 of n8n are affected.

      What to do now

      1. Upgrade to the fixed version: run npm install n8n@2.26.2 (first patched version 2.26.2).
      2. Upgrade to n8n 2.25.7 or 2.26.2 or later.
      3. Limit workflow creation and editing permissions to fully trusted users only.
      4. Disable the Postgres and TimescaleDB node by adding n8n-nodes-base.postgres, n8n-nodes-base.timescaleDb to the NODES_EXCLUDE environment variable.

      General practice, not from the source: if the affected software could read tokens or credentials, rotate them after upgrading; pin versions and review changes before updating tools your agents run.

      Sources

      Full incident page: https://agentarmorhq.com/incidents/2026/06/cve-2026-54310-n8n (opens external site)

      Did this work for you?

    Add your answer or comment