Am I affected by n8n: Stored XSS in Chat Trigger Node? What should I do?
An authenticated user with workflow edit access could inject arbitrary JavaScript into the Chat Trigger's generated page by setting a malicious
webhookId.Affected: n8n < 1.123.55, 2.0.0-rc.0 to 2.25.7, and 2.26.0 to 2.26.2. Fixed in: 1.123.55, 2.25.7, 2.26.2. What should you check, and what should you do about it?
Full incident page with sources: https://agentarmorhq.com/incidents/2026/06/cve-2026-54302-n8n (opens external site)
1 answer
Am I affected? Affected: n8n < 1.123.55, 2.0.0-rc.0 to 2.25.7, and 2.26.0 to 2.26.2. Fixed in: 1.123.55, 2.25.7, 2.26.2.
- Check your version: run
npm ls n8n. Versions < 1.123.55 of n8n are affected.
What to do now
- Upgrade to the fixed version: run
npm install n8n@1.123.55(first patched version 1.123.55). - Upgrade to n8n 1.123.55, 2.25.7, or 2.26.2 or later.
- Limit workflow creation and editing permissions to fully trusted users only.
- Disable the Chat Trigger node by adding
@n8n/n8n-nodes-langchain.chatTriggerto theNODES_EXCLUDEenvironment variable. - These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
General practice, not from the source: if the affected software could read tokens or credentials, rotate them after upgrading; pin versions and review changes before updating tools your agents run.
Sources
- GitHub Advisory Database: https://github.com/advisories/GHSA-42h7-m79w-wvg5 (opens external site)
Full incident page: https://agentarmorhq.com/incidents/2026/06/cve-2026-54302-n8n (opens external site)
Did this work for you?- Check your version: run