Am I affected by n8n: Credential Exfiltration via Permission Bypass? What should I do?
A member-level user with editor access to a shared workflow could reference credentials they do not own via specific public API endpoints.
Affected: n8n < 1.123.55, >= 2.0.0-rc.0 < 2.25.7, and >= 2.26.0 < 2.26.2. Fixed in: 1.123.55, 2.25.7, and 2.26.2. What should you check, and what should you do about it?
Full incident page with sources: https://agentarmorhq.com/incidents/2026/06/cve-2026-54307-n8n (opens external site)
1 answer
Am I affected? Affected: n8n < 1.123.55, >= 2.0.0-rc.0 < 2.25.7, and >= 2.26.0 < 2.26.2. Fixed in: 1.123.55, 2.25.7, and 2.26.2.
- Check your version: run
npm ls n8n. Versions < 1.123.55 of n8n are affected.
What to do now
- Upgrade to the fixed version: run
npm install n8n@1.123.55(first patched version 1.123.55). - Upgrade to n8n 1.123.55, 2.25.7, or 2.26.2 or later to remediate the vulnerability.
- Restrict workflow sharing to fully trusted users only.
- Audit shared workflows for unexpected credential references or recent modifications.
General practice, not from the source: if the affected software could read tokens or credentials, rotate them after upgrading; pin versions and review changes before updating tools your agents run.
Sources
- GitHub Advisory Database: https://github.com/advisories/GHSA-pmqw-72cg-wx85 (opens external site)
Full incident page: https://agentarmorhq.com/incidents/2026/06/cve-2026-54307-n8n (opens external site)
Did this work for you?- Check your version: run