Am I affected by n8n: Authenticated code execution in the n8n Git node? What should I do?
Using the Git node, under the default git security settings, by staging a crafted local repository, an attacker could cause git to run hooks.
Affected: npm/n8n < 1.123.67; >= 2.0.0-rc.0, < 2.31.5; >= 2.32.0, < 2.32.1. Fixed in: 1.123.67. What should you check, and what should you do about it?
Full incident page with sources: https://agentarmorhq.com/incidents/2026/07/ghsa-rcv6-pvrj-4xcg-n8n (opens external site)
1 answer
Am I affected? Affected: npm/n8n < 1.123.67; >= 2.0.0-rc.0, < 2.31.5; >= 2.32.0, < 2.32.1. Fixed in: 1.123.67.
- Check your version: run
npm ls n8n. Versions < 1.123.67 of n8n are affected.
What to do now
- Upgrade to the fixed version: run
npm install n8n@1.123.67(first patched version 1.123.67). - Upgrade to n8n 1.123.67, 2.31.5, or 2.32.1, or later.
- Restrict n8n instance access to fully trusted users only.
- Disable the Git node by adding n8n-nodes-base.git to the NODES_EXCLUDE environment variable.
- Restrict network egress from the n8n instance to limit the impact of arbitrary code execution.
General practice, not from the source: if the affected software could read tokens or credentials, rotate them after upgrading; pin versions and review changes before updating tools your agents run.
Sources
- GitHub Advisory Database: https://github.com/advisories/GHSA-rcv6-pvrj-4xcg (opens external site)
Full incident page: https://agentarmorhq.com/incidents/2026/07/ghsa-rcv6-pvrj-4xcg-n8n (opens external site)
Did this work for you?- Check your version: run