Am I affected by CodeWhale: Argument Injection in `git_show` Tool Allows Arbitrary File Write Without…? What should I do?
The
git_showtool in DeepSeek-TUI executesgit showwith the model-suppliedrevparameter passed unvalidated into the argv.Affected: npm/codewhale affected >= 0.8.41, < 0.8.64. Fixed in: 0.8.64. What should you check, and what should you do about it?
Full incident page with sources: https://agentarmorhq.com/incidents/2026/09/cve-2026-75913-codewhale (opens external site)
1 answer
Am I affected? Affected: npm/codewhale affected >= 0.8.41, < 0.8.64. Fixed in: 0.8.64.
- Check your version: run
cargo tree -i deepseek-tui. Versions >= 0.3.27, <= 0.8.41 of deepseek-tui are affected. - Check your version: run
npm ls deepseek-tui. Versions >= 0.3.27, < 0.8.41 of deepseek-tui are affected. - Check your version: run
cargo tree -i codewhale-tui. Versions >= 0.8.41, < 0.8.64 of codewhale-tui are affected.
What to do now
- Upgrade to the fixed version: run
npm install deepseek-tui@0.8.41(first patched version 0.8.41). - Upgrade to the fixed version: run
cargo update -p codewhale-tui --precise 0.8.64(first patched version 0.8.64). - Upgrade to 0.8.64 or later.
General practice, not from the source: if the affected software could read tokens or credentials, rotate them after upgrading; pin versions and review changes before updating tools your agents run.
Sources
- GitHub Advisory Database: https://github.com/advisories/GHSA-7j5w-7r7x-9v27 (opens external site)
Full incident page: https://agentarmorhq.com/incidents/2026/09/cve-2026-75913-codewhale (opens external site)
Did this work for you?- Check your version: run