Am I affected by n8n: Agent Workflow Tool Bypasses Sub-Workflow Caller Policy? What should I do?
A workflow's "This workflow can be called by" setting was enforced by the Execute Workflow node but was not consulted when the same workflow was attached to an Agent as a tool.
Affected: n8n < 2.37.7 and >= 2.38.0, < 2.38.2. Fixed in: 2.37.7. What should you check, and what should you do about it?
Full incident page with sources: https://agentarmorhq.com/incidents/2026/09/cve-2026-86996-n8n (opens external site)
1 answer
Am I affected? Affected: n8n < 2.37.7 and >= 2.38.0, < 2.38.2. Fixed in: 2.37.7.
- Check your version: run
npm ls n8n. Versions >= 2.38.0, < 2.38.2 of n8n are affected.
What to do now
- Upgrade to the fixed version: run
npm install n8n@2.38.2(first patched version 2.38.2). - Upgrade to n8n 2.37.7 or 2.38.2 or later.
- Restrict n8n instance access to fully trusted users only.
- Audit workflows attached as Agent tools and review their caller policy settings.
- Remove sensitive workflows from Agent tool configurations until the instance is patched.
General practice, not from the source: if the affected software could read tokens or credentials, rotate them after upgrading; pin versions and review changes before updating tools your agents run.
Sources
- GitHub Advisory Database: https://github.com/advisories/GHSA-7hgx-277f-7vmg (opens external site)
Full incident page: https://agentarmorhq.com/incidents/2026/09/cve-2026-86996-n8n (opens external site)
Did this work for you?- Check your version: run