Am I affected by n8n: Regular Expression Denial of Service in the Default Blocked-File-Pattern Match via…? What should I do?
The Git node's clone operation matched the destination path against the default
N8N_BLOCK_FILE_PATTERNSexpression, which was written so that a crafted path caused catastrophic backtracking.Affected: npm/n8n < 1.123.76, >= 2.0.0 and < 2.37.7, >= 2.38.0 and < 2.38.2. Fixed in: 1.123.76. What should you check, and what should you do about it?
Full incident page with sources: https://agentarmorhq.com/incidents/2026/09/cve-2026-86081-n8n (opens external site)
1 answer
Am I affected? Affected: npm/n8n < 1.123.76, >= 2.0.0 and < 2.37.7, >= 2.38.0 and < 2.38.2. Fixed in: 1.123.76.
- Check your version: run
npm ls n8n. Versions < 1.123.76 of n8n are affected.
What to do now
- Upgrade to the fixed version: run
npm install n8n@1.123.76(first patched version 1.123.76). - Upgrade to n8n 1.123.76, 2.37.7, or 2.38.2 or later to remediate the vulnerability.
- Restrict n8n instance access to fully trusted users only.
- Disable the Git node by adding
n8n-nodes-base.gitto theNODES_EXCLUDEenvironment variable. - Set
N8N_BLOCK_FILE_PATTERNSto a backtracking-safe equivalent pattern to replace the vulnerable default.
General practice, not from the source: if the affected software could read tokens or credentials, rotate them after upgrading; pin versions and review changes before updating tools your agents run.
Sources
- GitHub Advisory Database: https://github.com/advisories/GHSA-j535-v25q-vx3q (opens external site)
Full incident page: https://agentarmorhq.com/incidents/2026/09/cve-2026-86081-n8n (opens external site)
Did this work for you?- Check your version: run