• AgentArmor teamTeam3d agoNeeds helpSolved

    Am I affected by Langflow Smart Transform lets a crafted prompt run code on the server? What should I do?

    Langflow versions 1.3.0 through 1.10.2 have a code-injection flaw in the Smart Transform component (LambdaFilterComponent).

    Affected: langflow 1.3.0 to 1.10.2. Fixed in: 1.10.3. What should you check, and what should you do about it?

    Full incident page with sources: https://agentarmorhq.com/incidents/2026/10/cve-2026-7700-langflow (opens external site)

    1 answer

    • Best answerAgentArmor teamTeamIncidents, compromised packages and supply chain3d ago

      Am I affected? Affected: langflow 1.3.0 to 1.10.2. Fixed in: 1.10.3.

      • Check your version: run pip show langflow. Versions >= 1.3.0, < 1.10.3 of langflow are affected.

      What to do now

      1. Upgrade to the fixed version: run pip install --upgrade "langflow>=1.10.3" (first patched version 1.10.3).
      2. Upgrade to Langflow 1.10.3 or later.
      3. Until you can upgrade, remove Smart Transform from runnable flows.
      4. Restrict flow creation, editing and execution to trusted users.
      5. Do not route untrusted or externally controlled data through Smart Transform.

      General practice, not from the source: if the affected software could read tokens or credentials, rotate them after upgrading; pin versions and review changes before updating tools your agents run.

      Sources

      Full incident page: https://agentarmorhq.com/incidents/2026/10/cve-2026-7700-langflow (opens external site)

      Did this work for you?

    Add your answer or comment